Jump to content
CarPort ForumCarPort Forum

Lenkwinkelsensor codieren


H-Man
 Share

Recommended Posts

  • 2 weeks later...
vor 12 Stunden, Paulisch sagt:

lernt der sich nicht von alleine an wenn du das Lenkrad komplett nach rechts und dann komplett nach links lenkst?

der braucht doch nur die referenzpunkte 

Beim Golf 5 leider nein. Geht soweit ich weiß nur über die Grundeinstellung, was auch im Fehlerspeicher steht. (LWS keine Grundeinstellung)

Ab MQB (Golf 7) geht das meines Wissens ohne die Grundeinstellung.

Link to comment
Share on other sites

Aber wieso musst du denn den LWS neu codieren? Bzw. wieso sollte der neue LWS nicht mit der alten Codierung funktionieren?

Wenn du die Codierung änderst, veränderst du unter Umständen die Funktionsweise oder verstehe ich was falsch?

Vllt. kannst du den Code nicht speichern, weil die Codierung nicht geändert werden kann? Ist schließlich ein sicherheitsrelevantes 

Bauteil. Was steht denn in deinem Fehlerspeicher?

Link to comment
Share on other sites

  • 2 weeks later...

Hallo noch einmal zusammen,

habe die Grundeinstellung des Lenkwinkelsensors zwischenzeitlich hinbekommen. Im Prinzip funktioniert die Grundeinstellung mit Carport genauso wie bei VCDS.

Ich schildere euch noch einmal kurz, wie das bei einem Golf 5 Variant aus 2008 funktioniert. Die Vorgehensweise sollte bei anderen PQ Projekten (Polo,Tiguan, etc) identisch sein.

1. Motor starten und Lenkrad in Geradeausstellung drehen (Motor laufen lassen)

2. Carport Diagnose starten

3. Verbindung zum Steuergerät 03 (Bremsenelektronik) herstellen

4. Unter Login den Code 40168 eingeben um Zugangsberechtigung zu erhalten

5. Grundeinstellung öffnen und Block 060 auswählen/eingeben und Start klicken

6. 5-10m geradeaus fahren, anhalten, Lenkung auf Vollanschlag rechts drehen und kurz festhalten, das gleiche noch mal nach links und dann wieder in Geradeausstellung.

7. Klemme 15 Reset (Zündung aus und wieder an) und Fehler erneut auslesen (jetzt sollten keine Fehler mehr im STG 03 sowie STG 44 vorhanden sein)

8. Fertig

 

Das Ganze dauert ungefähr 10 Minuten. Mit etwas Routine und nem schnellen Rechner vllt. auch nur 5 Minuten ;)

 

Link to comment
Share on other sites

  • 7 months later...

Hallo,

was mach ich denn falsch, wenn nach dem Klicken auf Start, die Meldung bekomme:  "Anfrage außerhalb der Bereichsgrenzen"

Ist das ein Zeichen das der Lenkwinkelsensor defekt ist?

Habe bei mir den Fehler drauf: 00778 - Geber für Lenzwinkel  - keine oder falsche Grundeinstellung/Adaption, statisch

Könnte mir einer dabei weiter helfen?

Fahrzeug ist eine Skoda Rommster 5J, BJ 2009, 1,4l Benziner mit 83 PS

 

Danke im voraus.

 

Gruß

Heiko

Link to comment
Share on other sites

Wie bist Du vorgegangen? Anleitung von hier?

Welche Version wird benutzt und welcher Adapter?

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

MQB-Codierungen

Danke an die Ersteller und Pfleger der beiden Übersichten, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

Wenn Du den Code 40168 eingibst bekommst Du dort eine Bestätigung das der Code akzeptiert wurde?

Ich vermute der Code ist für den Roomster ein anderer, leider hab ich den richtigen auch nicht.

Kannst Du einen Diagnosebericht anhängen, die Teilenummer von den Steuergräten wäre interessant.

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

MQB-Codierungen

Danke an die Ersteller und Pfleger der beiden Übersichten, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

Ich bin mir nicht sicher, aber ich vermute Der Roomster hat noch die Lenkhilfe 2. Generation.

Die Grundeinstellung erfolgt dann im #44 vermutlich analog der Anleitung wie im Bremsensteuergerät.

Habe das bisher an einer Generation 2 noch nicht selbst gemacht, von daher ... Vermutung.

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

MQB-Codierungen

Danke an die Ersteller und Pfleger der beiden Übersichten, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

Hab heute mal Probiert.

In STG 03 kann ich mich mit 40168 einloggen, kann in Grundeinstellung Port 060 aufrufen aber nicht ohne Fehlermedung ausführen (Anfrage außerhalb der Bereichsgenzen).

In STG 44 kann ich mich weder mit 40168 und 19249 (was im Netz angegeben wird) einloggen, kann in Grundeinstellung Port 060 aufrufen und auch starten ohne fehlermeldung.

Bekomme den Fehler aber nicht weg, denke mal wegen dem Zugangscode.

Oder kann es an dem Lenkwinkelsensor liegen?

Komisch weise liefert der in STG 03 beim Auslesen Daten, die auch in 0° fast passen.

Wie kann ich feststellen ob der Sensor defekt ist?

 

Wenn ich das ABS-Einheit gewchselt habe (ist aus dem selben Model/Version), muss diese noch angepasst werden?

Wenn ja, weiß jemand wie?

Link to comment
Share on other sites

Hallo Heikoxxxxx,

ich weiß nicht ob dir das weiter hilft aber ich habe mal ein Problem mit dem ABS-Block an einem Seat Bj 2007 gehabt. Und zugleich leuchtete das ESP-Symbol und beim Auslesen auch ein Fehler im Lenkwinkelsensor. Also habe den ABS-Block getauscht und die Grundeinstellung (siehe weiter unten) durchgeführt trotzdem kein Erfolg. Dann sagte mir einer hier im Forum das ich bestimmt ein kaputten ABS-Block gekriegt habe, da ich die Grundeinstellung auch nicht hinbekommen habe. Also habe ich mir noch ein ABS-Block geholt (bei Kleinanzeigen, einer der die Teile Überholt verkauft), eingebaut, entlüftet und siehe da, aufeinmal klappte alles.

Ich habe es mit dieser Anleitung gemacht:

!!!!!Natürlich alles ohne Gewähr!!!!! Vllt hilft dir das weiter???

 

1. Schritt

 

Fahren Sie eine kurze Strecke, ca. 20m nicht schneller als 20km/h, dabei sollte das Lenkrad gerade stehen.

ACHTUNG die Lenkhilfe und das ESP arbeitet nur eingeschränkt.

Nach erfolgreichem Anlernen gehen die meisten Warnlampen aus, meistens bleibt das Servosymbol gelb (Lenkwinkelsensor).

Sollten alle Lampen aus sein haben Sie es schon geschafft, lesen Sie zur Sicherheit den Fehlerspeicher aus.

 

 

2. Schritt

 

Fahrzeug abstellen, Lenkrad gerade, Motor sollte aus sein.

 

Starten SieCarPort und wählen Sie Steuergerät 03 Bremsenelektronik.

Mit der Zugriffsberechtigung mit dem Login 40168 einloggen.

Wählen Sie Grundeinstellung - Block 066 Geber Bremsdruck (G201)

Der Wert im 2. Feld sollte i.O. und im 3. zwischen -3.8 und +3.8 sein.

Fertig.

 

3. Schritt

 

Erneut mit Zugriffsberechtigung mit dem Login 40168 einloggen.

Wählen Sie Grundeinstellung - Block 063 Geber Querbeschleunigung (G200)

Der Wert im 2. Feld sollte i.O. und im 3. zwischen -1.5 und +1.5 sein.

Fertig

 

4. Schritt

 

Mit der Zugriffsberechtigung mit dem Login 40168 einloggen.

Wählen Sie Grundeinstellung - Block 060 Geber Lenkwinkel (G85)

Der Wert im 2. Feld sollte i.O. und im 3. zwischen -1.5 und +1.5 sein.

Fertig, zurück

Steuergerät beenden, Zurück

 

 

5. Schritt

Wählen Sie Steuergerät 44 Lenkhilfe.

Mit der Zugriffsberechtigung mit dem Login 40168 einloggen.

Wählen Sie Grundeinstellung - Block 060 Lenkwinkelendanschlag

Sie sehen jetzt beim Bewegen des Lenkrads den aktuellenWinkel.

Drehen Sie jetzt das Lenkrad einmal bis Anschlag nach links und rechts

Fertig, zurück

 

7. Schritt

 

Machen Sie einen Fehlerscan und löschen Sie eventuell noch vorhandene alte Fehler.

Wenn alle relevanten Fehler verschwunden und alle Warnlampen aus sind beenden Sie CarPort und führen Sie eine Probefahrt wie in Schritt 1 beschrieben durch.

Link to comment
Share on other sites

Hallo Eugen88, 

Danke für deine Antwort, ich hatte deinen Text schon im Portal gesehen. 

Mein Problem ist, daß ich in STG 03 den Block 66 und 63 nicht ansprechen kann. So wie schon geschrieben mit Block 60.

Und in STG 44 bekomme ich mit 40168 keine Zugriffsrechte 😒

Kann aber den Block 60 ohne die Zugriffscode aufrufen, wird aber in den Feldern nichts angezeigt. Wäre schön, wenn ich davon mal ein Foto oder so bekommen könnte, damit ich mal einen Vergleich habe. 

Es sind bei mir alle Fehler, die vorher auf den Abs-Block den ich getauscht hatte bereits weg. Nach dem Tausch, habe ich jetzt den Fehler vom Lenkwinkelsensor im STG 03, der nach dem Löschen immer gleich wieder kommt. 

Muss man, um die Beschieben Blocks aufrufen zu können, etwas bestimmtes mit dem Fahrzeug machen? 

Danke erstmal für deine Mühen. 

Werde das ganze noch mal probieren. 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Hallo, 

Ich wollte mal eine Rückmeldung geben. Bin ja jetzt schon einige Zeit mit dem Lenkwinkelsensor beschäftigt, habe ja auch einige Tips bekommen (danke nochmal dafür). Leider hat nichts von dem geklappt 😔

Bin mit der Software nicht an das Steuergerät gekommen. Wüsste gerne warum. 

War gestern bei einem Kumpel der VCDS hat. Er hat sich ins Auto gesetzt, Stecker rein, Fehler auslesen und dann auf den Button für den Lenkwinkelsensor, OK, fertig. Ohne im Kreis zu fahren oder sonst irgend was 🤔

Fehler gelöscht und das wars. Wie ein Wunder 😁

Schade eigentlich das es mit meiner Software nicht so geht. 

Werde mir dazu mal Gedanken machen. 

 

Link to comment
Share on other sites

Dann kann das ein Bug in der Software sein, solltest Du dem Support melden, nur so kann der beseitigt werden.

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

MQB-Codierungen

Danke an die Ersteller und Pfleger der beiden Übersichten, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.