Jump to content
CarPort ForumCarPort Forum

Newby bittet um Hilfe


RedNose
 Share

Recommended Posts

Hallo,

 

ich habe mir das CPcompact incl. Por-Version und ODB für CAN-Bus gekauft.

Nun wollte ich mein "neues Spielzeug" auch gleich mal ausprobieren und mir die Spiegelheizung in meinem A3 (8P/ MJ 2004) frei schalten. Eine Anleitung habe ich http://www.stemei.de/pages/coding/audi-a3-8p/beheizbare-aussenspiegel.php gefunden. Da steht, das man den Wert im Steuergerät 42 bzw 52 um 32 erhöhen soll. Das ganze habe ich versucht, bin mir aber nicht sicher, ob ich alles richtig gemacht habe. Die Heizung der Spiegel ist ja abhängig von der Aussentemperatur ;-)

Also:

Ich habe einen Scan gemacht, das STG42 aufgerufen und den Wert (0000016) um 32 erhöht auf 0000048. dasselbe habe ich auch beim STG52 gemacht. Im Link steht auch, das man auch im STG9 Byte 01 das Bit 4 setzen kann. Das ging aber bei mir nicht, da ein Code verlangt wurde.

Ich habe das ganze mal als *jpg bzw als gekürztes PDF (Datei zu groß) angehängt.

 

Kann mir bitte jemand sagen, ob ich:

1) die programmierung der beiden Steuergeräte für die Spiegel (42 & 52) richtig gemacht habe

2) wo ich diesen Login - Code herbekomme?

3) ist der Code evtl. identisch mit dem "Werkstattcode" aus dem Diagnosebericht?

 

Sollte noch etwas benötigt werden, bitte melden.

Ich bin dann wieder ab ca. 16 Uhr wieder erreichbar ;-)

 

Schon mal vielen Dank.

 

MfG.

 

Ulli

 

post-1610-0-85088000-1409173996_thumb.jpgpost-1610-0-03688300-1409174002_thumb.jpgpost-1610-0-52075000-1409174006_thumb.jpgpost-1610-0-28421100-1409174009_thumb.jpgpost-1610-0-55361600-1409174012_thumb.jpgCarPort Diagnosebericht_2014-08-27.pdf

Link to comment
Share on other sites

1. Du kannst die Seite Stemei getrost löschen :D Das war das Erste, was ich gelernt habe, als ich das Spielzeug in den Händen hielt :)
2. Klick mich
3. pass da auf, es sind Anleitungen für mehrere Steuergeräte, du musst gucken, dass du die Anleitung für die richtige Byte-Anzahl nimmst. Die sind da immer alle direkt untereinander, könnte im ersten Moment verwirrend sein.
4. das habe ich alles jetzt so geschrieben, ohne nur ein Bild anzugucken :D
5. Ein paar Login-codes wirste da auch finden auf der Seite, ob für dich jetzt die passenden dabei sind, weiß ich nicht, weil ich dein BJ nicht kenne. 
6. Für weitere Infos bin ich auch noch zu newbie, allerdings wirste noch viel mehr spaß mit dem Spielzeug haben, weil du dein Auto jetzt erst richtig entdecken wirst :)

Gruß

 

 

Link to comment
Share on other sites

@DerMerklinder

zu 1. das ist mal unfug was Du da schreibst, warum sollte man sich dort keine Infos holen, es gibt dort wohl Codierungen die Fehlerhaft sind aber bei weitem nicht alle

zu 2. wenn Du einen Link setzt sollte der auch so sein das der Angeschriebene User dort für sein Fahrzeug brauchbare Infos findet zB so http://www.nikutronics.eu/home/info/v-a-g-obd

 

und im allgemeinen steht auf Nikutronics nichts anderes als RedNose schon gemacht hat.

TSTG 42 und 52 +32 ist richtig

BNSTG Byte1 Bit4 aktivieren ist auch richtig, egal wieviel Byte das STG hat, warum die Codierung abgewiesen wird kann ich von hier aus nicht sagen, da mir dazu Infos fehlen.

 

@RedNose der Audi hatte bisher keine Spiegelheizung? Wenn nicht, hast Du da was nachgerüstet?

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

Danke an djduese, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

wenn er doch alles richtig gemacht hat ist doch ok, Mit Stemei allerdings habe ich bisher nur schlechte Erfahrungen gemacht, und das nicht nur bei meinem Auto... Ich kann mich auf die Codes dort also überhaupt nicht verlassen, wenn ich z.B. Coming Home aktivieren will, 'n Häkchen setze und plötzlich geht mein Nebler aus, wenn ich ne Lichthupe mache :)
Klar, den Link hätte ich besser anders setzen sollen, bin jetzt davon ausgegangen, dass er einen Skoda hat, keine Ahnung warum.. aber auf Stemei sollte man sich besser nicht verlassen.. So ist meine Meinung

 

 

Link to comment
Share on other sites

@RedNose der Audi hatte bisher keine Spiegelheizung? Wenn nicht, hast Du da was nachgerüstet?

Hallo BeVo,

Ich hatte bis jetzt keine Speigelheizung.

Ich habe die beiden Spiegelgläser nachgerüstet. Die Teilenummer der Gläser hatte ich von den "A3-Freunde" und diese über Ebay gekauft. Der Umbau (alte Gläser raus, Stecker auf neue Gläser und neue Gläser rein) ging ohne Probleme.

Nochmal zur Info: ist ein A3 8P Modeljahr 2004 & EZ 09/2003 in der Ausstattung "Ambition". Da ich das Fahrzeig damals "gebraucht" gekauft habe, weis ich nicht, ob noch irgend ein "Sonderpaket" (z.B. Lichtpaket) dabei ist. Ich habe das Bose - Soundsystem (mit dem Radio Concert) und Xenon- sowie Nebellampen.

 

Wenn sonst noch was gebraucht wird, bitte melden.

 

Danke.

 

Ulli

Link to comment
Share on other sites

wenn er doch alles richtig gemacht hat ist doch ok, Mit Stemei allerdings habe ich bisher nur schlechte Erfahrungen gemacht, und das nicht nur bei meinem Auto... Ich kann mich auf die Codes dort also überhaupt nicht verlassen, wenn ich z.B. Coming Home aktivieren will, 'n Häkchen setze und plötzlich geht mein Nebler aus, wenn ich ne Lichthupe mache :)

Klar, den Link hätte ich besser anders setzen sollen, bin jetzt davon ausgegangen, dass er einen Skoda hat, keine Ahnung warum.. aber auf Stemei sollte man sich besser nicht verlassen.. So ist meine Meinung

 

Hallo DerMerklinder,

ich habe ja erst angefangen :)  Daher bin auch für jeden Link dankbar, auch wenn ich ihn evtl. nicht benutzen kann.

MfG

 

Ulli

Link to comment
Share on other sites

Setz mal das Häkchen bei Byte 1 Bit 4, ACHTUNG Byte 1 ist die 00 auch wenn da Byte 00 drin steht!

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

Danke an djduese, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

Setz mal das Häkchen bei Byte 1 Bit 4, ACHTUNG Byte 1 ist die 00 auch wenn da Byte 00 drin steht!

Ich glaub es kaum: kaum macht man es richtig, schon klappts :lol:

Ich habe dann bei 00 die 4 angeklickt, auf Speichern geklickt. Nun die Abfrage ob ich wirklich programmieren möchte angeklickt und bekam den oben beschriebenen Fehler wieder! Nur das das Steuergerät diesesmal die programmierung angenommen hat! Auch nach einigen Neustarts vom Auto und der Software ist der Hacken noch drinn.

 

Nun habe ich wieder etwas gelernt: Byte 1 ist eigentlich Byte 0.

 

Cool

 

Vielen Dank für die Infos an Euch beide.

 

MfG.

 

Ulli

Link to comment
Share on other sites

Ja das ist noch ein Bug, der hoffentlich bald gefixt wird.

Es freut mich das es funktioniert hat ;)

Nasenbohrer für Infos

Diagnoseinterface Diamex CP Compact, CarPort OBD,KKL Pro,CAN Pro

Fahrzeuge: Superb II Kombi Fl 2.0 TDI 170@200 PS | Skoda Kamiq 1.0 TSi | Superb III 2.0 TDI 4x4 190 PS |

Fehler Auslesen, Löschen, Anpassungen und Codierungen, VIM Freischaltungen (Audi) soweit möglich!

https://onedrive.live.com/view.aspx?resid=3AE6945C79E4C9E!17729&app=OneNote&authkey=!AMn8y885S2R-6Xg

Danke an djduese, für alle die das nutzen möchten Bitte haltet Euch an die Regeln!!! Danke

Link to comment
Share on other sites

Ja das ist noch ein Bug, der hoffentlich bald gefixt wird.

Es freut mich das es funktioniert hat ;)

Zu früh gefreut!!

Wie ich dann eben von der Arbeit heim gefahren bin, habe ich gemerkt, das Byte 000 doch Byte 000 ist! Als ich das Bit 4 gestern aktiviert hatte, bin ich nicht mehr gefahren. Erst später, als es dunkel war. Dadurch habe ich nicht gemerkt, das ich das "Tagfahrlicht (Nordamerika)" eingeschaltet habe. Ist erst eben (wie es hell war) aufgefallen. Er nimmt mir im Byte 001 das Bit 4 (heizbare Aussenspiegel verbaut) nicht an. Dafür kann ich aber den Heckwischer deaktivieren (Byte 001 / Bit 3). Toll.

Dann will ich mal hoffen, das irgendwer eine Lösung für mich hat.

 

MfG.

 

Ulli

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.