Jump to content
CarPort ForumCarPort Forum

Diamex DXM1 u. Carport


wbmobd
 Share

Recommended Posts

Hallo Forum

 

Auf meiner Suche nach OBD/OBD2 Software bin auch Carport gestoßen.

Die Software macht einen sehr guten Eindruck, so soll sie ja auch mit meiner neuen Errungenschaft zusammenarbeiten können...steht zumindest so unter Hardware.

 

Es handelt sich um ein Diamex DXM Starter Kit (DXM1-20)

Diesem Bausatz liegt modiag exress bei, eine reine OBD2 Software

 

Zu meiner eigentlichen Frage. Unter modiag wird das Interface erkannt, die Seriennummer angezeigt...es werden 9 Protokolle durchgesucht, es wird keines gefunden und abgebrochen. Ausgelesen wird ein älterer Golf3 Bj.94...dieser hat kein OBD2. Schalte ich das Interface in den Transitmodus wird es nicht als solches erkannt.Das geht alles iO...modiag unterstützt kein KW1281, auch keine KKL Interfacers.

 

Ganz anders zu Carport...hmm, Carport erkennt das DXM1 nur im Transitmodus als reines KKL Interface ohne Seriennummer. Der Golf lässt sich Problemlos auslesen, Fehlercodes usw was die Demo-Carport unterstützt.

Betreibe ich das Interface allerdings nicht im Transitmodus wird es nicht erkannt, es wird ewig gesucht....

 

Liegt es an der Demoversion das das DXM1 nicht erkannt wird. Ich habe starkes Interesse an der Pro Version von Euch in Can, OBD sowie KKL. Die Software sollte aber DXM abkönnen

 

Gruß und eine erfolgreiches neues Jahr wünscht

 

Thomas B.

Link to comment
Share on other sites

Hallo Alexander

 

Besten Dank für die wirklich schnelle Reaktion..so sollte Service/Support immer funktionieren.Guter Service spricht in meinen Augen auch für ein gutes Produkt

 

Mit der Beta klappt es auf Anhieb, angeschlossen...noch keine 15 sek später wurde das Interface im OBD2 Modus erkannt.

 

ODB2 per K-Line, Can, PWM sowie VPW, die Baudrate wird mit 57600 angezeigt, ebenso die Firmware des DXM1.....Klasse :)

 

Im reinen KKL Modus wird K-Line für OBD2/Volkswagen angezeigt

 

Gibt es neue Erkenntnisse in Richtung Pro Module u. ihren Erscheinen?

 

Gruß Thomas

Link to comment
Share on other sites

  • 5 months later...

Hallo Alexander,

 

ich habe das gleiche Problem wie Thomas mit dem DXM1-Modul.

Du hast ihm eine "CarPort 1.1.2 Beta" gebastelt, die das Problem behebt (bei Thomas wenigstens).

Leider ist der Link auf die Datei nicht mehr aktuell und ich kann es nicht testen.

 

Hier meine Konfiguration:

Diamex DXM1 V2.0, eingestellt auf 19200 Baud, 8N1

FTDI-Chip FT232RL, Defaulteinstellung, Treiber V2.08 auf WinXP

BT222 Bluetooth

Automatische Auswahl zwischen USB und Bluetooth über USB-Busspannung

(Dieses Interface ist eine Eigenentwicklung von meinem Ingenieurbüro)

 

Fahrzeug ist ein VW Touran Bj 2005.

Mit der moDiag_exp Software funktioniert die Verbindung als KKL Interface, Protokoll KWP2000 (5Baud Init) und im Transfermodus, natürlich nur für die OBDII-Funktionen.

USB und Bluetooth Schnittstelle verhalten sich gleich.

 

Mit CarPort_1.3.3 bekomme ich Verbindung nur im Transfermodus.

Ich habe das CAN-Modul freigeschaltet.

 

Hast du eine Idee, was da sein kann?

Viele Grüße aus Esslingen

Jochen

Link to comment
Share on other sites

Hallo andi.k

 

Vielen Dank für die schnelle Antwort. Bist wohl auch Nachtarbeiter.

 

Allerdings bin ich jetzt etwas verwirrt. In den Selbstudiumunterlagen von VW für den Touran (SSP307, Seiten 56/57) wird beschrieben, dass die Diagnose über den CAN-Bus geht, über die K-Leitung nur noch für OBD.

 

Zitat: "Diese Diagnoseleitungen sind für eine Datenübertragung auf dem CAN-Datenbus Diagnose geeignet.

Die bisherige K-Leitung wird noch zur Diagnose des Motor- und Getriebsteuergerätes im OBD-Modus genutzt. Daher ist die Diagnose mit anderen Diagnoseleitungen nur im Motorsteuergerät und im Steuergerät für automatisches Getriebe möglich."

 

Daher habe ich für CarPort nur das CAN-Modul freigeschaltet.

Wofür brauche ich das KKL-Modul?

 

Ich bin ab Ende des Monats mit meinem Touran ca. 3500 km weit weg von jeder VW-Vertragswerkstatt mit Diagnosegeräten. Daher möchte ich einen eigenen Diagnoseadapter dabei haben.

 

Euer Programm CarPort gefällt mir am besten von allen Programmen, die ich so kenne. Sowohl der Funktionsumfang als auch die Benutzerfreundlichkeit sind sehr gut. Glückwunsch für das gelungene Konzept!

 

Jetzt muss nur noch alles funktionieren wie gedacht.

 

Viele Grüße Jochen

Link to comment
Share on other sites

Hallo Joachim,

 

hier ist eine Version, bei der die DXM1 Erkennung mit 19200 Baud funktionieren sollte:

 

CarPort_1.3.3_DXM1_TEST_Setup.exe

 

Der Lawicel- bzw. CAN-Modus des DXM1 verwendet standardmäßig 57600 Baud. Hast Du eine andere Baudrate im Lawicel-Modus eingestellt ?

 

Ich vermute, daß die Kommunikation über Bluetooth im Lawicel-Modus mit den Steuergeräten durch höhere Latenzzeiten recht problematisch ist. Es wäre interessant, wenn Du mit deinem Bluetooth-DXM1 Latenzmessungen machen könntest.

 

Viele Grüße

Alexander

Link to comment
Share on other sites

Hallo Alexander,

 

Dankeschön für die Testversion. Die Verbindung CarPort<->DXM1 mit 19200 Baud klappt bei mir nicht.

 

Ich habe mal verschiedene Baudraten durchprobiert: mit 57600 Baud klappt es, Teilerfolg!

Dabei ist es egal, ob ich die Testversion oder die Normale 1.3.3 nehme.

 

Was jetzt noch fehlt, sind die grünen Häkchen bei "Volkswagen" :dry: .

 

So sieht der Bildschirm aus:

[img/]

 

Das ist meine CarPort Version:

[img/]

 

Und das im DXM1-Transit:

[img/]

 

Alle Test sind mit der FTDI-USB Schnittstelle gemacht. Diese läuft stabil und ohne zu zicken mit allen Baudraten. Der Test mit Bluetooth kommt, wenn USB in Ordnung geht.

Bluetooth läuft auf meinen (Windows)-Laptops nicht stabil. Auf meinem MAC gibts keine Probleme. Aber ich kenne keine OBD Software für den Mac, leider.

 

(Anmerkung: Die Vorschau funktioniert nicht, daher kann ich nicht testen, ob die Bilder angehängt wurden)

 

Viele Grüße

Jochen

Link to comment
Share on other sites

Joachim schrieb:

 

... Zitat: "Diese Diagnoseleitungen sind für eine Datenübertragung auf dem CAN-Datenbus Diagnose geeignet.

Die bisherige K-Leitung wird noch zur Diagnose des Motor- und Getriebsteuergerätes im OBD-Modus genutzt. Daher ist die Diagnose mit anderen Diagnoseleitungen nur im Motorsteuergerät und im Steuergerät für automatisches Getriebe möglich."

 

Daher habe ich für CarPort nur das CAN-Modul freigeschaltet.

Wofür brauche ich das KKL-Modul?

... Glückwunsch für das gelungene Konzept!

 

Jetzt muss nur noch alles funktionieren wie gedacht.

 

Viele Grüße Jochen

 

Das KKL-Modul/ Lizenz wird nicht benötigt. Der Zugriff zum STG 01 und 02 wird durch das Gatway geregelt, dass ein Zugriff per Can und KKL möglich ist. VW klemmt nach wie vor die K-/ und L-Leitung auf, dass die Diagnose für OBD2/ EOBD gem. der Norm möglich ist.

 

MfG firefox

Passat 3C/B6, CarPort CAN-Lizenzen, AGV4000B exp., WBH-Diag, moDiag, VCDS,

Link to comment
Share on other sites

Damit Du über den CAN-Bus kommunizieren kannst, mußt Du das DXM1-Modul in den Lawicel-Modus schalten. Ich habe das DXM1-Entwicklungsboard. Bei diesem muß ich einen Taster gedrückt halten, während sich das DXM1 im OBD2-Modus befindet. Eine Möglichkeit, den Adapter über ein Kommando in den anderen Modus zu schalten, ist mir derzeit nicht bekannt.

Link to comment
Share on other sites

Ich habe die gleiche Standardeinstellung, außer SB3 (57600). wenn ich auf atsb1 - atz gehe (also 19200) keine Verbindung. Ich hab nun 2 Fragen:

1. wie kann ich im Forum Bilder anhängen? Ich wollte dir screenshots schicken, die sagen mehr als Text.

2. das Umschalten mit dem Transit-Taster führt immer in den Transit-Modus, aber nicht in den CAN-LowLevel.

Die Unterlagen vom DXM-Entwicklerboard habe ich da, mein Stecker ist ganz ähnlich aufgebaut. Wie schaffst du es in den Lawicel-Modus?

Link to comment
Share on other sites

Du klickst bei "Bild zum Anhängen auswählen" auf "Datei auswählen", dann auf , dann auf "Vorschau" und dann auf "Absenden".

Da gibt es bei der Forensoftware noch einen Bug.

 

Bei mir muß ich den Taster für ca. 2 Sekunden im OBD2-Modus gedrückt halten, um in den Lawicel-Modus zu gelangen. In den KKL-Modus gelange ich nur, wenn ich den Taster während des Bootvorgangs der Firmware gedrückt halte.

Link to comment
Share on other sites

Aha, da ist also ein Unterschied im Verhalten. Bei meinem DXM ist es egal, ob ich beim booten drücke oder wenn schon 12 V anliegen. Da wir die gleiche DXM-Version haben (siehe Bild, stimmt das?), muss es an der Beschaltung liegen. Sind bei deinem Board noch Jumper gesteckt, z.B. für Mode1 oder Mode2 ?

Das Datenblatt für den DXM1 ist da ziemlich zurückhaltend mit Information.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.