Jump to content
CarPort ForumCarPort Forum

Bug bei Messwertbeschriftungen


Guest
 Share

Recommended Posts

Bei meinem MSG werden viele Messwerte in Carport falsch beschriftet.

 

Hat jemand das gleiche Problem und kennt eine Lösung?

 

Die Labeldatei wurde automatisch aus einem VCDS Labeldatei generiert (06B-907-557-ALT.lbl, Konvertierung ohne irgendwelche Fehlermeldungen oder Warnungen).

 

 

Bei mir wird z.B. für MWB 130 die Beschreibung vom MWB 003 angezeigt:

 

post-50-0-38537700-1544275721_thumb.png

 

Das betrifft wiegesagt mehrere Messwertblöcke und scheint ein Bug in Carport zu sein.

 

Hier der zugehörige Auszug aus der Labeldatei:

"block_003": {
	"description": {
		"en": "General"
	},
	"value_01": {
		"description": {
			"en": [
				"Engine Speed",
				"(G28)"
			]
		},
		"note": {
			"en": [
				"Range: 0...6500 RPM",
				"Specification (Idle): 700...960 RPM"
			]
		}
	},
	"value_02": {
		"description": {
			"en": [
				"Mass Air Flow",
				"Sensor (G70)"
			]
		},
		"note": {
			"en": [
				"Range: 0.0...150.0 g/s",
				"Specification (Idle): 2.0...4.5 g/s",
				"Specififcation (Load): min. 95.0 g/s"
			]
		}
	},
	"value_03": {
		"description": {
			"en": "Throttle Valve Angle"
		},
		"note": {
			"en": [
				"Range: 0.0...100.0 %",
				"Specification (Idle): 0.0...2.0 %"
			]
		}
	},
	"value_04": {
		"description": {
			"en": [
				"Ignition",
				"Timing Angle"
			]
		},
		"note": {
			"en": [
				"Range: -20.0...+50.0 °BTDC",
				"Specification (Idle): 0.0...12.0 °BTDC"
			]
		}
	}
},

.....

"block_130": {
	"description": {
		"en": "Engine Cooling (Map Cooling)"
	},
	"value_01": {
		"description": {
			"en": [
				"Engine Outlet",
				"Temperature"
			]
		}
	},
	"value_02": {
		"description": {
			"en": [
				"Radiator Outlet",
				"Temperature"
			]
		}
	},
	"value_03": {
		"description": {
			"en": [
				"Thermostat",
				"Duty Cycle"
			]
		},
		"note": {
			"en": [
				"Range: 0.0...100.0 %"
			]
		}
	},
	"value_04": {
		"description": {
			"en": [
				"Map Cooling",
				" System Test"
			]
		},
		"note": {
			"en": [
				"Range: Test ON/Test OFF/Syst. OK/Syst. n.OK",
				"Specification: Test OFF"
			]
		}
	}
},
Link to comment
Share on other sites

Tut mir leid - die Version hatte ich vergessen zu nennen.

 

Ich hatte versucht, es mit der neuesten Version zu testen (2.3.4), aber dort werden mir mangels Lizenz nur die ersten 3 MWB angezeigt...

 

Leider reicht meine Lizenz nur bis CarPort_2.3.0_beta5 und hier tritt der Fehler auf.

 

Ich habe auch die Konvertierung mit beiden Versionen ausprobiert, aber in beiden Fällen kommt ein identisches json-File raus => am Labelfile-Konverter liegt's nicht.

Link to comment
Share on other sites

Sehr gut! Dann habe ich mir doch glatt mal das Update gegönnt...

 

...und es funktioniert!

 

Mir hat jedoch die alte Messwerte-Anzeige deutlich besser gefallen da übersichtlicher / besser ablesbar und weniger verschenkter Platz auf dem Bildschirm... Wär schön wenn man optional zur alten Ansicht umschalten könnte...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.