Jump to content
CarPort ForumCarPort Forum

Standheizung im ausgebauten Zustand auslesen


Martin
 Share

Recommended Posts

Hallo,

 

der Versuch eine Eberspächer D4WS (Bj. 99, original im T4 verbaut), die im eingebauten Zustand über die OBD-Schnittstelle auszulesen ist (K-Interface), scheitert, weil kein Diagnosehardware erkannt wird.

Das über Bluetooth verbundene DXM 1-17 Interface (über +12V-, GND- Diagnose-Pin an das Steuergerät des Heizers angeschlossen) würd für ca. 1 Sekunde kurz erkannt.

 

Andere ODB-Tools (Freeware) erkennen das Diagnose-Interface über Bluetooth sicher, können aber das Steuergerät des Heizers nicht auslesen.

Was kann hier helfen?

 

MfG

Martin

Link to comment
Share on other sites

Hi Martin

 

Hast du Probleme mit dem DXM oder dem auslesen der Standheizung allgemein? Die mussten beim T4 immer angeschalten sein um den Fehlerspeicher auslesen zu können. Kannst du Sie im ausgebauten Zustand überhaupt soweit verkabeln das sie theoretisch anlaufen würde?

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hallo Sepp,

 

die Verkabelung sieht wie folgt aus (8-poliger Stecker):

 

Pin 1 --> 12V (Klemme 30)

Pin 2 --> GND (Klemme 31)

Pin 5 --> Diagnose / K-Line (mit 560 Ohm pull up Widerstand an 12V)

Pin 7 --> Einschaltsignal auf 12V

 

Damit sollte der Heizer soweit aktiviert sein, dass ein Auslesen möglich ist.

 

Ob die Verbindung DXM(via Bluetooth) oder das Steuergerät das Problem ist, kann ich z. Z. nicht sagen. Mit andrer OBD-Software z.B. Modiag oder Torque(Android) habe ich einen stabilen Zugriff über das Motorsteuergerät auf ODB-2 Werte gehabt.

 

MfG

 

Martin

Link to comment
Share on other sites

Was ist mit dem Zuheizersignal an Pin 6 vll. brauchst du das auch? Hab leider auch noch nie probiert eine im ausgebauten Zustand auszulesen.

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Vielleicht auch noch interessant

 

 

Während der Zuheizer nur über eine Diagnoseuhr ausgelesen werden kann, verfügt die werkseitig verbaute D4WS über einen Diagnoseanschluss, der an den Leitungsverteiler für die Eigendiagnose angeschlossen werden kann. Dies gilt aber nur dann, wenn das Heizgerät zuvor in einem VW-Modell verbaut war, weil nur dann die für die Diagnose erforderliche VW-Software aufgespielt ist. Falls ein defektes Steuergerät mit VW-spezifischer Software durch ein handelsübliches mit Eberspächer-Software ersetzt wird, muss der Diagnoseanschluss des Heizgeräts unbedingt vom Leitungsverteiler für die Eigendiagnose abgezogen werden, weil ansonsten der Diagnose-Bus des gesamten Fahrzeugs lahmgelegt wird.

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hallo Sepp,

 

ja, den Aussentemperaturschalter (pin 6) habe ich auch schon auf 12V gelegt - ohne Erfolg.

Und ja, es handelt sich um ein Steuergerät mit VW Software, das in der Vergangenheit auch schon mal über die OBD-Schnittstelle ausgelesen wurde.

 

Was mich irritiert, ist die kurze Anzeige des erfolgten Verbindungsaufs. Meine Vermutung ist, das CarPort den Adapter erkennt, aber kein Motorsteuergerät findet und die Verbindung wieder abbricht - das wäre schade...

 

Gruß

 

Martin

Link to comment
Share on other sites

Martin schrieb:

Pin 5 --> Diagnose / K-Line (mit 560 Ohm pull up Widerstand an 12V)

 

Legst du die K-Leitung auf + 12V!?

Wird die K-Leitung nicht durchs Steuergerät intern mit 12V versorgt!? Glaube da brauchen wir den Rat einer der Admins da mein Wissen da dann auch am Ende ist.

 

CarPort braucht kein Motorsteuergerät oder CAN Gateway um die Verbindung aufzubauen. Einfach über Steuergeräteauswahl -> Fahrzeugauswahl (T4) -> Stand- / Zusatzheizungheizung reingehen.

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Welches Diagnoseinterface verwendest du? Dein Bluetooth DXM ist für die herstellerspezifische Diagnose nicht geeignet.

Du benötigst eine normales USB KKL-Interface (AutoDia K409 oder ähnlich). Wenn du das Steuergerät ausgebaut hast, dann musst du auf der Startseite den COM-Port manuell wählen, da die automatische Hardwareerkennung über das (normalerweise vorhandene) Motorsteuergerät läuft.

 

Grüße

Jens

Link to comment
Share on other sites

Hallo Jens,

 

der Adapter kommuniziert zwar über Bluetooth mit dem PC/CarPort besitz aber K-Line Funktionalität. Zumindest wird versucht das Motorsteuergerät "aufzuwecken", das habe ich überprüft.

 

Wenn ich Deinen Hinweis umsetzte, erhalte ich die Meldung:

Verbunden mit KKL-Interface, Adapter nicht bereit.

 

Und die Steuergeräteauswahl in der Programmoberfläche ist inaktiv.

 

MfG

 

Martin

Link to comment
Share on other sites

Eine herstellerspezifische Diagnose über Bluetooth wird nicht funktionieren, da die Latenzen einfach zu groß sind.

Das KW1281-Protokoll ist extrem zeitkritisch; da kann man über eine Serielle-Bluetooth-Verbindung nichts machen (haben wir alles schon probiert ;-) ).

Kannst du den Diagnoseadpater auch direkt über USB anschließen? Ansonsten solltest du Dir ein einfaches USB KKL-Interface (z.b. AutoDia K409) besorgen.

Link to comment
Share on other sites

Hallo Jens,

 

vielen Dank für den Hinweis auf das kritische Timing. Ich habe mir kurz ein Adapter/Level-shifter gestrickt. Damit kann ich den Heizer unter Steuergerät 18 erreichen (KWP1281). Also schon mal ein Stück weiter.

Nur Fehler sehe ich noch nicht, der Autoscan stoppt mit der Meldung --> siehe Bild.

 

MfG

 

Martin

Link to comment
Share on other sites

Hallo Jens,

 

weil ich keine Fehlerwerte lesen konnte und die ganze Verbindung "harkte".

 

Mittlerweile ist es mir gelungen, den Fehlerspeicher auszulesen. Ein Rücksetzen oder Löschen des Fehlerspeichers funktioniert aber immer noch nicht. Die Verbindung zum Steuergerät lässt sich auch nicht zurücksetzen.

Was kann hier jetzt noch falsch sein?

 

MfG

 

Martin Carport_2.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.