Jump to content
CarPort ForumCarPort Forum

Radio codieren?


refietze
 Share

Recommended Posts

Hi Reinhold,

 

Bei VW, Audi (also denk ich auch mal Skoda) kann man dem Radio über die kurze Codierung sagen welche Lautsprecher verbaut sind, ob ein AUX-In Anschluss vorhanden ist usw...

Leider findet man im Internet nirgends genauere Infos zu den Radiocodierungen. :(

Musste mir die Codierliste für mein altes RCD310 welches ich in den Polo 6R meines Paps verpflanzt habe über eine technische Anfrage bei VW holen. Trotz Kooperationsvertrag rücken die solche Daten auch an uns immer nur mit "Zähneknirschen" raus. :angry:

 

Steck das Radio einfach mal rein und schau obs funktioniert (Sollte es eigentlich lt. unserem erfahrenen Car-Audio Nachbarn). Danach kannst ja mal den Fehlerspeicher des Radios prüfen ob irgendwelche Fehlercodes vorhanden sind.

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hallo Sepp,

hatte das Radio eben einmal Probehalber ins Auto gesteckt (brauche noch einige Teile zum finalen Einbau).

Radio spielt auf allen 4 Kanälen.

Fehlermeldungen, falls vorhanden, werde ich am Wochenende auslesen wenn ich den endgültigen Einbau mache. Falls Fehlermeldungen erscheinen wird ich mich noch einmal melden.

 

Schon mal vielen Dank für die schnelle Antwort, ohne Leute wie DICH wäre solch ein Forum doch um einiges ärmer. :) :) :)

 

Gruß

Reinhold

Link to comment
Share on other sites

Kein Thema. Falls er Fehler setzen sollte schau ich mal ob ich bei Skoda was erreiche. Viel Spass beim Einbau am Wochenende und ab nächster Woche beim fahren mit Musi. :cheer:

 

Gruß Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hallo Reinhold,

 

hab alles durchforstet was ich habe und leider nix gefunden ob und wo man was codieren muss / kann. Leider!!! Kannst dir höchstens mal im CAN Gateway den Messwertblock 140 zu gemüte führen, da ist die Kommunikation fürs Radio drinnen.

 

Solltest vielleicht dann doch nochmal beim :) deines Vertrauens vorstellig werden damit dieser die Codierung vom Radio prüft.

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hallo,

ich möchte hier mal die Fortschritte meines Vorhabens dokumentieren, vielleicht hilft es später anderen die vor dem gleichen Problem stehen.

 

Also ich hab die Fehlermeldungen im Can-Gateway (19) und in der Zentralelektronic (09) folgendermaßen weg bekommen:

im Can Gateway (19) die bestehende Codierung (bei mir 00014) einfach neu codieren mit dem gleichen Wert, dadurch werden wohl alle vorhandenen Steuergeräte neu in die Verbauliste eingetragen.

 

Dadurch waren schon einmal die Fehler im Can-Gateway und in der zentralelektronic verschwunden.

 

Die letzte Fehlermeldung im Radio (56) lautet:

03138 Eingang AUX IN

Unterbrechung, statisch

 

Diese Fehlermeldung hab ich leider immer noch, in Carport Beta 7_1 ist dafür die lange Codierung vorgesehen und es müssen Sachen an- oder abgewählt werden.

Leider ist diese Codierung noch nicht kommentiert und ich weiss nicht welchen Haken ich setzen oder entfernen muss.

Bei meinen Versuchen (Haken setzen, Codierung speichern, Haken entfernen, Codierung speichern)

kam immer die Fehlermeldung "Codierung abgelehnt" o.ä.

 

Vielleicht kann mir irgend Jemand dazu etwas sagen?

Ich hab schon im Radio den AUX-Eingang ausgeschaltet aber die Fehlermeldung bleibt bestehen.

 

Gruß

Reinhold

 

 

Edit:

 

So hab jetzt alle Fehlermeldungen weg.

Ich hab einfach im Radio (56)folgenden Haken entfernt:

Byte 000 Bit 2

dann auf Codierung speichern.

Danach kommt die Fehlermeldung "Codierung falsch" oder ähnlich aber die neue Codierung wird trotzdem übernommen.

Zündung aus, Zündung an und Tätterättääää:

 

Fehlermeldung AUX-IN W E G

 

Im Anhang noch der letzte Scan.......

 

Gruß

Reinhold 20.pdf

Link to comment
Share on other sites

  • 5 months later...

Hallo Reinhold,

 

ist ja interessant, was du da schreibst ... ich habe ein ähnliches Problem mit meinem Radio ...

Habe ein Kenwood DNX521VBT mit CAN-Bus für VAG-Fahrzeuge.

 

Und auch bei mir habe ich im Diagnoseinterface für Datenbus (STG 19) eine Fehlermeldung fürs Radio.

 

Ich benutze jetzt aber die CarPort 2.0.0 beta7_7 Software und dort ist für den Datenbus die lange Codierung vorgesehen.

Was muss ich jetzt machen?

 

Vielen Dank für jede Hilfe. :)

 

meinerkleiner

Diagnosebericht_14_02_27.pdf

Link to comment
Share on other sites

Hi

 

habe das selbe Radio und die selbe Meldung hab ich auch  :)  (Das Kenwood hat ja keine VAG Diagnosemöglichkeit). Du könntest das Radio aus der Verbautliste im Gateway auscodieren (darauf achten das danach noch alles funktioniert) oder einfach mit der Fehlermeldung weiter leben. Die macht nämlich garnichts...

 

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hallo Sepp,

 

noch eine Frage zu "unserem" Kenwood-Radio?

Hast du ein Multifunktionslenkrad (MFL)?

Hast du da eventuell was umcodiert, damit du mehr Anzeigen im MFD+ hast,

bzw. kann man die Tasten am Lenkrad auch anders codieren?

Ich hab nämlich bei einigen Tasten am Lenkrad die selbe Funktion.

 

Danke.

meinerkleiner

Link to comment
Share on other sites

Ja habe MFL und ein CAN Bus Adapter ist auch verbaut ums das MFL nutzen zu können. Dieser stellt in der MFA+ leider nur die PDC Anzeige dar und sonst nichts. Titelanzeige, Navianzeige oder ähnliches leider fehlanzeige. Die Adapterbox ist leider nicht Diagnosefähig und kann nicht codiert werden. Die Tasten am Lenkrad funktionieren aber alle Einwandfrei.

 

Habe das Radio + DVB-T + Subwoofer + besagten Adapter nicht selbst verbaut sondern von einem guten Freund welcher langjährige (30 Jahre mittlerweile) Erfahrung mit Carhifisystemen hat und sich auskennt wie kein anderer. Beschreib mal deinen Fehler näher, dann frag ich ihn mal woran das liegen kann.

 

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

ist ja interessant ... ich habe es ähnlich

MFL, aber ab Werk ohne Telefonfreisprecheinrichtung

CAN-Bus Adapter für das Kenwood ...

 

und auch das MFA+ ... aber dort wird mir die PDC nicht angezeigt, sondern nur im Display des Radios ->
Wie hast du dass denn eingestellt, dass es auch im  MFD+ angezeigt wird ????

 

Zu den Tasten am Lenkrad funktionieren auch alle ... hier eine Aufstellung:

 

 

Links: Drehrad:    laut/leise = funktioniert;
                            Druck auf das Drehrad = funktioniert: Audioquellen im Kenwood wechseln (Tuner, DVD, USB usw.)

          Pfeiltasten: funktionieren (je nach Einstellung der "Seek"-Funktion am Radio)

                             nächster bzw. vorheriger abgespeicherter Radiosender,

                             manueller oder automatischer Suchlauf am Radio

          

Rechts: Drehrad: MFD+: im Menü die zur Verfügung gestellten Infos anzeigen  = funktioniert

                            bzw. scollen in den Menüs der Einstellungen ...

                            Druck auf das Drehrad = Wechsel zwischen Speicher 1 (2-Stunden-Speicher)

                                                                    und Speicher 2 (Dauerspeicher)

                                                                    bzw. "Enter"-Funktion in den Einstellmenüs

             Rücktaste: Wechsel zwischen Menü MFD, Audio, Einstellungen, Serviceanzeige  

 

             Kreissymbol: gleiche Funktion wie Druck auf Drehrad links (Wechsel der Audioquellen)

 

           

Und genau da wünsch ich mir, dass ich hier die Telefontaste programmiert bekommen (also Gepräch annehmen und auflegen). Wie gesagt, ab Werk war das Radio ohne FSE eingebaut. Aber ich kann mir nicht vorstellen, dass sie deshalb gleich ein anderes Lenkrad /Kabelbaum ect. eingebaut haben. Also müsste man dem Steuergerät doch nur sagen: Ja, du hast eine FSE .... und dann sollte es doch klappen ??? Das war die Frage: Kann man diese Kreispfeile umprogrammieren?

 

Vielen Dank fürs Rumhören.

 

Meinerkleiner

          

post-1113-0-40306900-1394613150_thumb.jpg

post-1113-0-62844800-1394613150_thumb.jpg

Link to comment
Share on other sites

Gib mir mal bitte die Codierung vom Lenksäulensteuergerät. Ich glaube da kann man die PTT (Push to Talk) Funktion codieren. Muss aber erst die Hotline bemühen, da ich für dieses Steuergerät keine Unterlagen habe, dauert also mal ne Stunde (oder auch 2) ;)

 

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Hier sind die Angaben zum Steuergerät: (und es ist wieder dieses blöde UDS-Protokoll :( )

 

Lenkradelektronik (0x16)
Allgemeine Informationen
Teilenummer 5K0 953 521 AT Beschreibung LENKS.MODUL  014 0140
Codierung Lange Codierung
Werkstattinformationen Werkstattcode: 73430  Importeur: 790  Gerätenummer: 00083
Kommunikation
Protokoll UDS Bus CAN
Transportprotokoll ISO TP (CAN 11-Bit) Baudrate 500000
Erweiterte Identifikation
Seriennummer 20120927800741 Datum 26.09.12
Identifikation URB-001 Herstellernummer P4PQ
Systemname Prüfstandsnummer 0414
Flash Status
Programmierversuche 0 Programmierstatus 00000000
Erfolgreiche Programmierungen 0 Programmiervorbedingungen
Zusätzliche Informationen
Hardwarenummer 5K0 953 569 B
Revision FF010041
Keine gespeicherten Fehler

 

Danke ... das wäre super

meinerkleiner

Link to comment
Share on other sites

Dann müssen wir mit dem codieren wohl auf die beta_8 warten :eek:

 

Bei mir wird die Anzeige der PDCs dafür nicht im Radio angezeigt :mellow:

Denke mal, dass das wirklich vom CAN Bus Adapter abhängig ist...

 

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

  • 2 months later...

So lieber Sepp ...

 

und nun noch zu diesem offenen Problem ...

 

Wie oben beschrieben, wolltest du (jetzt nachdem das UDS-Protokoll funktioniert)  ...

doch mal die Hotline kontaktieren ... um die Einstellungen für mein Lenksäulensteuergerät zu erfragen ...

 

Damit ich meine Taste am Radio für den Telefonbetrieb freischalten kann ... Du sagst bei dir klappt das ja  ...

 

und damit das ganze auch klappt, bleibt auch noch zu klären, ob ich irgendwo noch codieren muss, dass eine Telefon-Freisprecheinrichtung installiert ist ...

 

na dann bin ich ja mal gespannt ...

Danke und an schearnen Gruß

aus dem Nordosten der Rebuplik ...

 

meinerkleiner

Link to comment
Share on other sites

Hi zum 3. mal heute

 

 

schau mal ob im besagten Steuergerät

 

Byte1 Bit1 = MFL via LIN Bus (LIN 2.0) verbunden

Byte1 Bit3 = MFL mit PTT (push-to-talk) verbaut.

 

aktiviert ist. Weitere Sachen bezüglich MFL sind in der Liste nicht vorhanden.

 

 

MfG Sepp

Diagnoseinterface: CP compact, Menke Diag 1000, AutoDIA K409 + K509

Module: CarPort OBD, KKL, CAN

Fahrzeuge: GolfVI 1,4TSI, Polo(6R) 1,4, Audi Cabriolet (Typ89) 2,0E

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.